const regex = new RegExp('^(?!.* )(?!.*[-,/.]{2})(?!.*(?:[^\\d\\n]*\\d){6})(?!.*([a-zA-Z])\\1\\1).{3,50}$', 'gm')
const str = `Time Square, Main Road, 2279
Time-Square, Main Road-2279
Time Square Main Road
Time Square, Main Road, 22798741313
Time Square, Main Road..
Time Square, Main Road//
Time Square Main Road,,
Time Square Main Road--
-------
--//
--/
ttttttttttttttttttttttttttt
/-/-/-/-
-/-
-/-
.,.
,-,
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}