#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:https?:\/\/)?w{3})(?:[.].*|)|(?:https?:?\/\/(?!w{1,2}\.).*))$"
Local $sString = "https://" & @CRLF & _
"http://" & @CRLF & _
"https://www." & @CRLF & _
"http://www." & @CRLF & _
"www." & @CRLF & _
"wwwsa.se" & @CRLF & _
"http://ww." & @CRLF & _
"http://www." & @CRLF & _
"ww." & @CRLF & _
"www." & @CRLF & _
"www//" & @CRLF & _
"www.g" & @CRLF & _
"https://wix" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")