$re = '/^(?:(?:(?:https?:\/\/)?w{3})(?:[.].*|)|(?:https?:?\/\/(?!w{1,2}\.).*))$/m';
$str = 'https://
http://
https://www.
http://www.
www.
wwwsa.se
http://ww.
http://www.
ww.
www.
www//
www.g
https://wix
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);