import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:https?:\\/\\/)?w{3})(?:[.].*|)|(?:https?:?\\/\\/(?!w{1,2}\\.).*))$";
final String string = "https://\n"
+ "http://\n"
+ "https://www.\n"
+ "http://www.\n"
+ "www.\n"
+ "wwwsa.se\n"
+ "http://ww.\n"
+ "http://www.\n"
+ "ww.\n"
+ "www.\n"
+ "www//\n"
+ "www.g\n"
+ "https://wix\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}