const regex = /^(?:(?:(?:https?:\/\/)?w{3})(?:[.].*|)|(?:https?:?\/\/(?!w{1,2}\.).*))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?:https?:\\\/\\\/)?w{3})(?:[.].*|)|(?:https?:?\\\/\\\/(?!w{1,2}\\.).*))$', 'gm')
const str = `https://
http://
https://www.
http://www.
www.
wwwsa.se
http://ww.
http://www.
ww.
www.
www//
www.g
https://wix
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}