import re
regex = re.compile(r"^(?:(?:(?:https?:\/\/)?w{3})(?:[.].*|)|(?:https?:?\/\/(?!w{1,2}\.).*))$", flags=re.MULTILINE)
test_str = ("https://\n"
"http://\n"
"https://www.\n"
"http://www.\n"
"www.\n"
"wwwsa.se\n"
"http://ww.\n"
"http://www.\n"
"ww.\n"
"www.\n"
"www//\n"
"www.g\n"
"https://wix\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")