#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{9,12}$"
Local $sString = "123456789" & @CRLF & _
"12345678912" & @CRLF & _
"hello1234567890" & @CRLF & _
"string with valid 123456789012" & @CRLF & _
"also va123456789id" & @CRLF & _
"also va1234567890id" & @CRLF & _
"also va12345678901id" & @CRLF & _
"also va123456789012id" & @CRLF & _
"inv123456lid" & @CRLF & _
"inv1234567890123lid" & @CRLF & _
"string with invalid 123456" & @CRLF & _
"string with invalid 12345678901234" & @CRLF & _
"shouldn't match" & @CRLF & _
"123456" & @CRLF & _
"1234567891234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")