import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{9,12}$";
final String string = "123456789\n"
+ "12345678912\n"
+ "hello1234567890\n"
+ "string with valid 123456789012\n"
+ "also va123456789id\n"
+ "also va1234567890id\n"
+ "also va12345678901id\n"
+ "also va123456789012id\n"
+ "inv123456lid\n"
+ "inv1234567890123lid\n"
+ "string with invalid 123456\n"
+ "string with invalid 12345678901234\n"
+ "shouldn't match\n"
+ "123456\n"
+ "1234567891234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}