import re
regex = re.compile(r"^\d{9,12}$", flags=re.MULTILINE)
test_str = ("123456789\n"
"12345678912\n"
"hello1234567890\n"
"string with valid 123456789012\n"
"also va123456789id\n"
"also va1234567890id\n"
"also va12345678901id\n"
"also va123456789012id\n"
"inv123456lid\n"
"inv1234567890123lid\n"
"string with invalid 123456\n"
"string with invalid 12345678901234\n"
"shouldn't match\n"
"123456\n"
"1234567891234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")