$re = '/^\d{9,12}$/m';
$str = '123456789
12345678912
hello1234567890
string with valid 123456789012
also va123456789id
also va1234567890id
also va12345678901id
also va123456789012id
inv123456lid
inv1234567890123lid
string with invalid 123456
string with invalid 12345678901234
shouldn\'t match
123456
1234567891234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);