const regex = /^\d{9,12}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{9,12}$', 'gm')
const str = `123456789
12345678912
hello1234567890
string with valid 123456789012
also va123456789id
also va1234567890id
also va12345678901id
also va123456789012id
inv123456lid
inv1234567890123lid
string with invalid 123456
string with invalid 12345678901234
shouldn't match
123456
1234567891234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}