#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^000\.(?:[36]|000\.|100\.1|400\.(?:0|100))$"
Local $sString = "000.000." & @CRLF & _
"000.100.1" & @CRLF & _
"000.3" & @CRLF & _
"000.400.0" & @CRLF & _
"000.400.100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")