$re = '/^000\.(?:[36]|000\.|100\.1|400\.(?:0|100))$/m';
$str = '000.000.
000.100.1
000.3
000.400.0
000.400.100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);