re = /^000\.(?:[36]|000\.|100\.1|400\.(?:0|100))$/m
str = '000.000.
000.100.1
000.3
000.400.0
000.400.100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end