using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^000\.(?:[36]|000\.|100\.1|400\.(?:0|100))$";
string input = @"000.000.
000.100.1
000.3
000.400.0
000.400.100";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}