// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^000\.(?:[36]|000\.|100\.1|400\.(?:0|100))$").unwrap();
let string = "000.000.
000.100.1
000.3
000.400.0
000.400.100";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}