import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(?:\\s*\\|+\\s*\\w+\\s*)*$";
final String string = "COMMENT — CODE | COUNTRY | DATE | TARGET\n"
+ "CODE| COUNTRY | DATE |TARGET\n"
+ "CODE|| COUNTRY| DATE |TARGET\n"
+ "COMMENT 1 — COMMENT 2 — CODE | COUNTRY | DATE | TARGET";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}