$re = '/\w+(?:\s*\|+\s*\w+\s*)*$/m';
$str = 'COMMENT — CODE | COUNTRY | DATE | TARGET
CODE| COUNTRY | DATE |TARGET
CODE|| COUNTRY| DATE |TARGET
COMMENT 1 — COMMENT 2 — CODE | COUNTRY | DATE | TARGET';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);