// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+(?:\s*\|+\s*\w+\s*)*$").unwrap();
let string = "COMMENT — CODE | COUNTRY | DATE | TARGET
CODE| COUNTRY | DATE |TARGET
CODE|| COUNTRY| DATE |TARGET
COMMENT 1 — COMMENT 2 — CODE | COUNTRY | DATE | TARGET";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}