import Foundation
let pattern = #"\w+(?:\s*\|+\s*\w+\s*)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
COMMENT — CODE | COUNTRY | DATE | TARGET
CODE| COUNTRY | DATE |TARGET
CODE|| COUNTRY| DATE |TARGET
COMMENT 1 — COMMENT 2 — CODE | COUNTRY | DATE | TARGET
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)