package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)%`)
var str = `
"1%"
"10%"`
var substitution = "$1.0%"
fmt.Println(re.ReplaceAllString(str, substitution))
}