use strict;
my $str = '
"1%"
"10%"';
my $regex = qr/(\d+)%/mp;
my $subst = '$1.0%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";