$re = '/(\d+)%/m';
$str = '
"1%"
"10%"';
$subst = "$1.0%";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;