const regex = /(\d+)%/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)%', 'gm')
const str = `
"1%"
"10%"`;
const subst = `$1.0%`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);