#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((\+?(61\W?4))|(04))\W?(([0-9]{2}\W[0-9]{3}\W[0-9]{3})|([0-9]{8})|([0-9]{4}\W[0-9]{4})|([0-9]{2}\W[0-9]{6}))$"
Local $sString = "0412345678" & @CRLF & _
"65+656" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")