import Foundation
let pattern = #"^((\+?(61\W?4))|(04))\W?(([0-9]{2}\W[0-9]{3}\W[0-9]{3})|([0-9]{8})|([0-9]{4}\W[0-9]{4})|([0-9]{2}\W[0-9]{6}))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0412345678
65+656
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}