// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^((\+?(61\W?4))|(04))\W?(([0-9]{2}\W[0-9]{3}\W[0-9]{3})|([0-9]{8})|([0-9]{4}\W[0-9]{4})|([0-9]{2}\W[0-9]{6}))$").unwrap();
let string = "0412345678
65+656
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}