package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((\+?(61\W?4))|(04))\W?(([0-9]{2}\W[0-9]{3}\W[0-9]{3})|([0-9]{8})|([0-9]{4}\W[0-9]{4})|([0-9]{2}\W[0-9]{6}))$`)
var str = `0412345678
65+656
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}