$re = '/^((\+?(61\W?4))|(04))\W?(([0-9]{2}\W[0-9]{3}\W[0-9]{3})|([0-9]{8})|([0-9]{4}\W[0-9]{4})|([0-9]{2}\W[0-9]{6}))$/';
$str = '0412345678
65+656
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);