#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)exports\.(\w+).*(\n.*?){1,}fooMethod"
Local $sString = "exports.methodOne = async user_id => {" & @CRLF & _
" // other method contents" & @CRLF & _
"};" & @CRLF & _
"exports.methodTwo = async user_id => {" & @CRLF & _
" // other method contents" & @CRLF & _
" fooMethod();" & @CRLF & _
"};" & @CRLF & _
"exports.methodThree = async user_id => {" & @CRLF & _
" // other method contents" & @CRLF & _
" fooMethod();" & @CRLF & _
"};"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")