re = /exports\.(\w+).*(\n.*?){1,}fooMethod/m
str = 'exports.methodOne = async user_id => {
// other method contents
};
exports.methodTwo = async user_id => {
// other method contents
fooMethod();
};
exports.methodThree = async user_id => {
// other method contents
fooMethod();
};'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end