using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"exports\.(\w+).*(\n.*?){1,}fooMethod";
string input = @"exports.methodOne = async user_id => {
// other method contents
};
exports.methodTwo = async user_id => {
// other method contents
fooMethod();
};
exports.methodThree = async user_id => {
// other method contents
fooMethod();
};";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}