package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)exports\.(\w+).*(\n.*?){1,}fooMethod`)
var str = `exports.methodOne = async user_id => {
// other method contents
};
exports.methodTwo = async user_id => {
// other method contents
fooMethod();
};
exports.methodThree = async user_id => {
// other method contents
fooMethod();
};`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}