import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "exports\\.(\\w+).*(\\n.*?){1,}fooMethod";
final String string = "exports.methodOne = async user_id => {\n"
+ " // other method contents\n"
+ "};\n"
+ "exports.methodTwo = async user_id => {\n"
+ " // other method contents\n"
+ " fooMethod();\n"
+ "};\n"
+ "exports.methodThree = async user_id => {\n"
+ " // other method contents\n"
+ " fooMethod();\n"
+ "};";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}