using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!retargetting).)*(annual)((?!retargetting).)*$";
string input = @"Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will match anything containing ""annual"" but not ""retargetting""
1 this only contains annual
2 this does not
3 annual retargetting
4 retargetting annual
5 words words annual words words
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}