import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!retargetting).)*(annual)((?!retargetting).)*$";
final String string = "Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will match anything containing \"annual\" but not \"retargetting\"\n\n"
+ "1 this only contains annual\n"
+ "2 this does not\n"
+ "3 annual retargetting\n"
+ "4 retargetting annual\n"
+ "5 words words annual words words \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}