const regex = /^((?!retargetting).)*(annual)((?!retargetting).)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!retargetting).)*(annual)((?!retargetting).)*$', 'gmi')
const str = `Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will match anything containing "annual" but not "retargetting"
1 this only contains annual
2 this does not
3 annual retargetting
4 retargetting annual
5 words words annual words words
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}