re = /^((?!retargetting).)*(annual)((?!retargetting).)*$/mi
str = 'Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will match anything containing "annual" but not "retargetting"
1 this only contains annual
2 this does not
3 annual retargetting
4 retargetting annual
5 words words annual words words
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end