use strict;
my $str = 'Any line with HIGHLIGHTING is a match. Lines with no highlighting would be filtered out. This regex will match anything containing "annual" but not "retargetting"
1 this only contains annual
2 this does not
3 annual retargetting
4 retargetting annual
5 words words annual words words
';
my $regex = qr/^((?!retargetting).)*(annual)((?!retargetting).)*$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}