const regex = new RegExp('^https://[^/]+/(.*)', 'gm')
const str = `https://example.com/`;
const subst = `https://test.com/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);