$re = '`^https://[^/]+/(.*)`m';
$str = 'https://example.com/';
$subst = "https://test.com/$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;