re = /^https:\/\/[^\/]+\/(.*)/m
str = 'https://example.com/'
subst = 'https://test.com/$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result