use strict;
my $str = 'https://example.com/';
my $regex = qr`^https://[^/]+/(.*)`mp;
my $subst = 'https://test.com/$1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";