using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"start[\S\s]+?(captureme)[\S\s]+?end";
string input = @"case 1:
start
captureme
suffix
end
case 1.5:
start
prefix
suffix
end
case 2:
start
prefix
captureme
suffix
end";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}