re = /start[\S\s]+?(captureme)[\S\s]+?end/
str = 'case 1:
start
captureme
suffix
end
case 1.5:
start
prefix
suffix
end
case 2:
start
prefix
captureme
suffix
end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end