import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "start[\\S\\s]+?(captureme)[\\S\\s]+?end";
final String string = "case 1:\n"
+ "start\n"
+ "captureme\n"
+ "suffix\n"
+ "end\n\n"
+ "case 1.5:\n"
+ "start\n"
+ "prefix\n"
+ "suffix\n"
+ "end\n\n"
+ "case 2:\n"
+ "start\n"
+ "prefix\n"
+ "captureme\n"
+ "suffix\n"
+ "end";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}