$re = '/start[\S\s]+?(captureme)[\S\s]+?end/';
$str = 'case 1:
start
captureme
suffix
end
case 1.5:
start
prefix
suffix
end
case 2:
start
prefix
captureme
suffix
end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);