import re
regex = re.compile(r"start[\S\s]+?(captureme)[\S\s]+?end")
test_str = ("case 1:\n"
"start\n"
"captureme\n"
"suffix\n"
"end\n\n"
"case 1.5:\n"
"start\n"
"prefix\n"
"suffix\n"
"end\n\n"
"case 2:\n"
"start\n"
"prefix\n"
"captureme\n"
"suffix\n"
"end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")