#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\*ext-vscode-rickroll-start\*\/[\s\S]*?\/\*ext-vscode-rickroll-end\*\/"
Local $sString = "/*ext-${vscode-rickroll}-start*/" & @CRLF & _
"@keyframes doRick{" & @CRLF & _
" from {" & @CRLF & _
" transform: scale(2);" & @CRLF & _
" opacity:1;" & @CRLF & _
" }" & @CRLF & _
" to {" & @CRLF & _
" transform: scale(1);" & @CRLF & _
" opacity:0.7;" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"body{" & @CRLF & _
" animation: doRick 1.8s linear 1 normal forwards;" & @CRLF & _
" background-size:contain;" & @CRLF & _
" opacity:1;" & @CRLF & _
" animation-delay: 2.4s;" & @CRLF & _
" background-repeat: no-repeat;" & @CRLF & _
" background-position:center center;" & @CRLF & _
" background-image:url('${base64image}'); " & @CRLF & _
"}" & @CRLF & _
"/*ext-${vscode-rickroll}-end*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")