# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\*ext-vscode-rickroll-start\*\/[\s\S]*?\/\*ext-vscode-rickroll-end\*\/"
test_str = ("/*ext-${vscode-rickroll}-start*/\n"
"@keyframes doRick{\n"
" from {\n"
" transform: scale(2);\n"
" opacity:1;\n"
" }\n"
" to {\n"
" transform: scale(1);\n"
" opacity:0.7;\n"
" }\n"
"}\n"
"body{\n"
" animation: doRick 1.8s linear 1 normal forwards;\n"
" background-size:contain;\n"
" opacity:1;\n"
" animation-delay: 2.4s;\n"
" background-repeat: no-repeat;\n"
" background-position:center center;\n"
" background-image:url('${base64image}'); \n"
"}\n"
"/*ext-${vscode-rickroll}-end*/")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.